ParentSquare Slow Load Times
Incident Report for ParentSquare
Resolved
We have confirmed that the issue is resolved. We are analyzing the root cause of the issue and will provide an update.
Posted Sep 11, 2023 - 12:07 PDT
Monitoring
The issue appears to be resolved. We are continuing to monitor the system.
Posted Sep 11, 2023 - 11:32 PDT
Update
While we work to troubleshoot the issue, some users may be temporarily disconnected from ParentSquare. We will provide an update as soon as the issue is resolved.
Posted Sep 11, 2023 - 11:03 PDT
Investigating
We are currently investigating in issue that is causing ParentSquare to load slowly for users.
Posted Sep 11, 2023 - 11:01 PDT
This incident affected: Web Application.