Our application has experienced an issue with notification delivery statistics.
Incident Report for ParentSquare
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 09:08 PST
Update
All delivery reports should now be up to date. We will continue to monitor our reporting systems.
Posted Jan 23, 2023 - 15:01 PST
Monitoring
Features that provide notification status and delivery reports are impacted. Our system is recovering, but delivery reports may be delayed as much as 3 hours.

All other features and functions, including notification deliveries, work as expected.

Our team is working on the issue; please check this page for up-to-the-minute information.
Posted Jan 23, 2023 - 14:16 PST
This incident affected: Web Application.