Slow Loading Times
Incident Report for ParentSquare
Resolved
Pages have continued to load normally, and we can confirm that the issue is resolved.
Posted Dec 08, 2023 - 13:33 PST
Monitoring
The issue has been resolved, and we are monitoring to confirm that pages continue to load normally.
Posted Dec 08, 2023 - 11:29 PST
Investigating
We are investigating an issue where the ParentSquare web application is loading slowly for some users.
Posted Dec 08, 2023 - 11:19 PST
This incident affected: Web Application.