Texts and Voice Calls Delay

Incident Report for ParentSquare

Resolved

We confirmed that the issue has been resolved.
Posted Sep 01, 2026 - 10:46 PDT

Monitoring

We are monitoring texts and phone calls as the provider incident continues.
Posted Sep 01, 2026 - 10:39 PDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 10:32 PDT

Investigating

One of our SMS and voice call providers has reported an incident. We are investigating and we will provide an update shortly.
Posted Sep 01, 2026 - 10:01 PDT
This incident affected: Texts and Phone Calls.