ParentSquare application is slow to respond

Incident Report for ParentSquare

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 16:21 PST

Monitoring

The latency has subsided from the spike that triggered this incident. The team is continuing to monitor.
Posted Nov 14, 2025 - 15:43 PST

Investigating

We are currently investigating this issue.
Posted Nov 14, 2025 - 14:44 PST
This incident affected: Web Application and iOS and Android Mobile Applications.