Email Delivery Delayed
Incident Report for ParentSquare
Resolved
Our email delivery provider confirmed that the email delivery delay is fully resolved. All emails sent through ParentSquare should be delivered according to normal timeframes.
Posted Jan 22, 2024 - 17:20 PST
Monitoring
Our email delivery provider confirmed that they implemented a fix for the email delivery delay. We are monitoring to confirm that emails are delivering normally.
Posted Jan 22, 2024 - 16:40 PST
Identified
We received an alert that our email delivery provider is currently experiencing delays in sending emails, which impacts any emails sent through ParentSquare. We will provide an update when we learn more.
Posted Jan 22, 2024 - 16:25 PST
This incident affected: Emails.