Smart Sites Slowness

Incident Report for ParentSquare

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 08:53 PDT

Investigating

Smart Sites is currently experiencing slower than usual site loading times. Our engineering team is investigating the issue.
Posted Aug 19, 2026 - 08:33 PDT
This incident affected: Smart Sites.