Users Unable to Log into ParentSquare

Incident Report for ParentSquare

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 06:59 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 06:32 PDT

Investigating

We are investigating reports that some users are not able to log into ParentSquare. We will provide an update shortly.
Posted Apr 08, 2026 - 06:24 PDT
This incident affected: Web Application.