Issue Loading ParentSquare Pages for Some Users Resolved

Incident Report for ParentSquare

Resolved

For approximately 15 minutes, some users experienced an issue where they weren't able to load some ParentSquare pages on our web and mobile applications. This was due to a network configuration issue. We confirmed that the issue has been resolved, and pages should be loading correctly for all users.
Posted Aug 12, 2025 - 14:30 PDT