ParentSquare Dashboards not loading

Incident Report for ParentSquare

Resolved

We confirmed that the issue has been resolved.
Posted Apr 28, 2025 - 08:32 PDT

Monitoring

We have implemented a fix and are monitoring the results.
Posted Apr 28, 2025 - 08:25 PDT

Investigating

We are investigating reports that ParentSquare Dashboards are not loading. We will provide an update shortly.

A workaround is to use the www.parentsquare.com/districts//feeds or www.parentsquare.com/schools//feeds link instead. Please fill in with your specific institute id.
Posted Apr 28, 2025 - 08:02 PDT
This incident affected: Web Application.