Text Message Delivery May be Delayed

Incident Report for ParentSquare

Resolved

We confirmed that the issue has been resolved.
Posted Jun 24, 2025 - 09:57 PDT

Monitoring

We have implemented a fix and are monitoring the results.
Posted Jun 24, 2025 - 09:49 PDT

Identified

We have identified the cause of the issue and are implementing a fix.
Posted Jun 24, 2025 - 09:40 PDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2025 - 09:36 PDT

Investigating

We are investigating reports that text messages are not being delivered. We will provide an update shortly.
Posted Jun 24, 2025 - 09:25 PDT
This incident affected: Texts.