Slow Load Times
Incident Report for ParentSquare
Resolved
We have confirmed that the issue is fully resolved, and the associated delays with the delivery of emails, text messages, phone calls, and app notifications have also been resolved.
Posted Oct 30, 2023 - 14:12 PDT
Monitoring
The slow loading times have been resolved, and we are continuing to monitoring the system to ensure that the issue remains resolved. Delivery of some emails, text messages, phone calls, and app notifications may be delayed as the system recovers. We will provide an update when those delays are resolved as well.
Posted Oct 30, 2023 - 08:59 PDT
Identified
We have implemented a fix for the slow loading times and are monitoring the system to confirm that all functions are loading as expected.
Posted Oct 30, 2023 - 08:39 PDT
Investigating
The ParentSquare web and mobile applications are currently experiencing slow load times.

We are investigating the issue and will provide updates.
Posted Oct 30, 2023 - 07:47 PDT
This incident affected: Web Application and iOS and Android Mobile Applications.