Text Message Delivery May be Delayed

Incident Report for ParentSquare

Resolved

We confirmed that the issue has been resolved. All affected text messages have been processed.
Posted May 28, 2025 - 11:28 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 11:04 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 28, 2025 - 10:55 PDT

Investigating

We are investigating reports that some users are not receiving text messages as quickly as expected.
Posted May 28, 2025 - 10:47 PDT
This incident affected: Texts.