Issues with accessing web and mobile apps

Incident Report for ParentSquare

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:37 PDT

Update

The ParentSquare web application and mobile applications have fully recovered.
Posted Oct 20, 2025 - 13:36 PDT

Update

ParentSquare continues to recover and users are able to perform most functions. Our team is actively investigating and working with AWS to resolve slowness users may experience loading certain pages and error messages that a limited number of users may be seeing.

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 09:27 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:29 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:09 PDT

Monitoring

AWS has implemented some fixes to their environment, and ParentSquare services are recovering. Many ParentSquare users are now able to successfully access the services.
Posted Oct 20, 2025 - 08:01 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 07:28 PDT

Identified

Multiple ParentSquare services are currently unavailable due to a significant Amazon Web Services (AWS) outage. Our team is diligently working with AWS to resolve the problem.
Posted Oct 20, 2025 - 07:21 PDT
This incident affected: Web Application, Texts, Smart Sites, iOS and Android Mobile Applications, and Social Network Sharing.