Virtual Phone Outbound Call Delivery

Incident Report for ParentSquare

Update

We are continuing to investigate this issue.
Posted Aug 13, 2026 - 16:01 PDT

Investigating

Some outbound Virtual Phone calls are not connecting or are going straight to voicemail. We have identified the cause as carrier spam filtering applied to the numbers these calls are placed from. We are working with our voice provider and with the carrier analytics providers to rectify the issue and restore normal delivery. This is unfolding with great urgency, and we expect increasing resolution to this issue in the coming days.
Posted Aug 13, 2026 - 12:36 PDT
This incident affects: Phone Calls.