Issue with Multiple Notifications

Incident Report for ParentSquare

Resolved

We confirmed that the issue has been resolved.
Posted Mar 18, 2025 - 18:01 PDT

Monitoring

We are investigating reports that some Posts sent multiple notifications earlier this afternoon. We will provide an update shortly.

We are not seeing any indications that the issue is ongoing or impacting current Posts.
Posted Mar 18, 2025 - 17:13 PDT
This incident affected: Texts, Emails, and iOS and Android Mobile Applications.