Smart Sites Document Upload Failures

Incident Report for ParentSquare

Resolved

The issue has now been resolved.
Posted Jul 28, 2026 - 12:17 PDT

Identified

We have identified the cause of the issue and are implementing a fix.
Posted Jul 28, 2026 - 12:08 PDT

Investigating

We are investigating reports that document folders in Smart Sites may appear empty and that new document uploads are failing. We will provide an update shortly.
Posted Jul 28, 2026 - 12:02 PDT
This incident affected: Smart Sites.