Customers unable to download custom versions of their school's app

Incident Report for ParentSquare

Resolved

We confirmed that the issue has been resolved.
Posted Mar 31, 2026 - 08:20 PDT

Update

The issue has been resolved, thank you for your patience.
Posted Mar 31, 2026 - 08:18 PDT

Investigating

We are investigating reports that the page for downloading custom versions of the ParentSquare app is showing errors. We are investigating and will provide an update shortly.
Posted Mar 31, 2026 - 06:34 PDT
This incident affected: Web Application.