Email Delivery May be Delayed

Incident Report for ParentSquare

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 10:30 PST

Monitoring

We have identified the issue as a temporary service degradation. Delivery rates have returned to normal levels, and we are monitoring the situation to ensure continued stability. We will provide a final update once we are confident the issue is fully resolved.
Posted Feb 24, 2026 - 09:57 PST

Investigating

We are investigating reports that some users are not receiving email notifications as quickly as expected. We will provide an update shortly.
Posted Feb 24, 2026 - 09:43 PST
This incident affected: Emails.