Gmail Delays

Incident Report for ParentSquare

Resolved

Google's Gmail service disruption has been resolved.
Posted Apr 08, 2026 - 16:21 PDT

Monitoring

Google is currently experiencing a Gmail service disruption that may cause a delay sending emails to gmail.com addresses and other Google-hosted email accounts. We're actively monitoring the disruption.

You may also experience a delay sending any ParentSquare support requests by email. Until the disruption is resolved, please contact ParentSquare Support through the in-application "Chat With Us" option in the help menu.
Posted Apr 08, 2026 - 13:35 PDT