Emails Sent to Yahoo, AOL, and Verizon Addresses Delayed
Incident Report for ParentSquare
Resolved
As of Friday, March 29, emails are successfully being delivered to Yahoo-managed email accounts, including yahoo.com, aol.com, and verizon.com. We have received confirmation from Yahoo that they made some changes on their end that resolved the issue, and as a result, deliveries to these email accounts should now be operating normally.
Posted Apr 01, 2024 - 18:46 PDT
Monitoring
The email delivery issue for Yahoo-managed email services, such as yahoo.com, aol.com, and verizon.com, appears to be resolved, and emails to these addresses were successfully delivered today.

We are continuing to monitor email delivery for these addresses to confirm that the issue remains resolved.
Posted Mar 29, 2024 - 20:41 PDT
Update
We unfortunately do not yet have an update on the source of this issue. We have confirmed that this issue appears to be affecting only Yahoo-managed email services, and email services run by other providers such as Google and Microsoft do not appear to be impacted. We also confirmed that we did not make any changes to how ParentSquare sends email prior to the start of this issue.

We are continuing to work with our email delivery providers to identify the source of the issue and will provide an update as soon as we learn more.
Posted Mar 28, 2024 - 12:07 PDT
Investigating
Some customers have reported that ParentSquare emails being sent to yahoo.com, aol.com, and verizon.com email addresses are being delayed. We are working with Yahoo, which provides the email service for those domains, to identify the cause of the issue, and will provide an update when we learn more.
Posted Mar 27, 2024 - 15:38 PDT
This incident affected: Emails.