The maintenance is complete and all systems are operating normally.
Posted Apr 24, 2026 - 10:50 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2026 - 10:45 PDT
Identified
We will be performing emergency maintenance today, April 24, at 10:45 AM Pacific Time/1:45 PM Eastern Time.
We expect downtime to be limited to 2 minutes, but are reserving up to 5 minutes.
During this time, ParentSquare and all related services will be unavailable. We apologize for the short notice. There is instability with one of our underlying system components hosted by AWS, and we are conducting this emergency maintenance to maintain the reliability of the system.
Posted Apr 24, 2026 - 09:57 PDT
This incident affected: Web Application, Texts, Emails, Phone Calls, Smart Alerts, Auto Notices, Smart Sites, Data Sync, Support Systems, iOS and Android Mobile Applications, and Social Network Sharing.